gnome-settings-daemon crash details

problems with Gnome: after trying to change my icon theme from within an Xgl(Beryl) session, gnome-settings-daemon crashed. Now will not start on Gnome startup.

gdb trace (from a failsafe session) gives:

(no debugging symbols found)
[New Thread -1228379232 (LWP 7074)]

(gnome-settings-daemon:7068): GSwitchIt-WARNING **: Unable to connect to dbus: Unable to determine the address of the message bus (try 'man dbus-launch' and 'man dbus-daemon' for help)

** (gnome-settings-daemon:7068): CRITICAL **: dbus_g_connection_register_g_object: assertion `connection != NULL' failed

** (gnome-settings-daemon:7068): CRITICAL **: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed

** (gnome-settings-daemon:7068): CRITICAL **: dbus_g_proxy_call: assertion `DBUS_IS_G_PROXY (proxy)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1226680656 (LWP 7068)]
0x0806915d in keyboard_config_registry_get_type ()

EDIT: fixed now. problem was due to me being a retard and installing the redhat-artwork RPM using alien so that I could use the bluecurve icon set. simply removed the package and extracted the cons manually from the rpm and stuck them in home/shrimphead/.icons works fine now.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s


%d bloggers like this: