Archive for the ‘Linux’ Category

Fluxbox progress

February 21, 2007

hehe although my tutorial is not quite finish (it’s coming in the next few days I promise :P) in the mean time have another nice fluxbox screenshot, this is what my desktop looks like as of today

apps are thunar, gnome-terminal, conky. Themes are Tempura GTK and Tempura Fluxbox. The wallpaper came from http://www.animepaper.net

screenie

Advertisements

Fluxbox

February 8, 2007

At the request of a friend of mine from the Ubuntu forums I am currently writing a tutorial on how to configure and set up fluxbox on Ubuntu edgy. Hopefully I should be finished at some point in the next week when the completed tutorial will be posted somewhere on the vastness of the internet 🙂

I hadn’t realised how much work just a simple little config howto would be so props to all the howto writers and wiki editors whose work I have previously taken for granted. thanks 😛

just a few little reminders for myself :
aleczapka-artwiz fonts (snap)
Tempura theme: a nice looking fluxbox theme that I found on http://www.boxwhore.org (this is not dodgy 😛 it’s merely a website for people like myself who love the *box :D)


./configure --enable-kde --enable-gnome --enable-xrender

gnome-settings-daemon crash details

January 9, 2007

problems with Gnome: after trying to change my icon theme from within an Xgl(Beryl) session, gnome-settings-daemon crashed. Now will not start on Gnome startup.

gdb trace (from a failsafe session) gives:

(no debugging symbols found)
[New Thread -1228379232 (LWP 7074)]

(gnome-settings-daemon:7068): GSwitchIt-WARNING **: Unable to connect to dbus: Unable to determine the address of the message bus (try 'man dbus-launch' and 'man dbus-daemon' for help)

** (gnome-settings-daemon:7068): CRITICAL **: dbus_g_connection_register_g_object: assertion `connection != NULL' failed

** (gnome-settings-daemon:7068): CRITICAL **: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed

** (gnome-settings-daemon:7068): CRITICAL **: dbus_g_proxy_call: assertion `DBUS_IS_G_PROXY (proxy)' failed

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1226680656 (LWP 7068)]
0x0806915d in keyboard_config_registry_get_type ()

EDIT: fixed now. problem was due to me being a retard and installing the redhat-artwork RPM using alien so that I could use the bluecurve icon set. simply removed the package and extracted the cons manually from the rpm and stuck them in home/shrimphead/.icons works fine now.

latest ATI drivers in Ubuntu

January 9, 2007

First edit xorg.conf and change

Driver "fglrx"

to

Driver "vesa"

and add

Section "Extensions"
Option "Composite" "Disable"
EndSection


install everything required to build a debian kernel module
(note: older fglrx needs to be uninstalled)

apt-get update
apt-get install module-assistant build-essential wget fakeroot dh-make debconf libstdc++5 linux-headers-$(uname -r)

Now add

DISABLED_MODULES="fglrx"

to/etc/default/linux-restricted-modules-common
(just in case!)

now go and get the latest driver package (note get the .run file not the rpm)
then build:

chmod +x ati-driver-installer-8.32.5-x86.x86_64.run ./ati-driver-installer-8.32.5-x86.x86_64.run --buildpkg Ubuntu/edgy
dpkg -i xorg-driver-fglrx_8.32.5-1_i386.deb fglrx-kernel-source_8.32.5-1_i386.deb fglrx-control_8.32.5-1_i386.deb
rm /usr/src/fglrx-kernel*.deb
sudo mkdir -p /usr/src/modules/fglrx/linux
sudo touch /usr/src/modules/fglrx/linux/config.h

rebuild the kernel module

module-assistant prepare
module-assistant update
module-assistant build fglrx
module-assistant install fglrx depmod -a
aticonfig --initial aticonfig --overlay-type=Xv

(note: some further editing of xorg.conf may be necessary to actually set the default screen and card to the new drivers, check this then reboot)

My Current Gnome Screenshot

December 27, 2006

I figure this has been uploaded to the Ubuntu forums so it may as well go here too:

Gnome

FYI: The guy in the background is one of the guitarists from a Japanese HC band called Envy, they rule! Thanks to some guy on Last.fm for the pic

Current Desktop

December 19, 2006

My current desktop

currently having a problem with conky

shrimphead@sakura:~$ conky
Conky: on_bottom is deprecated. use own_window_hints below
Conky: forked to background, pid is 6495
Conky: desktop window (3e) is root window
Conky: drawing to desktop window
Conky: failed to set up double buffer
Conky: drawing to single buffer

simple fix:

add


Section "Modules"
Load "dbe"

to xorg.conf

Yet another OSS Blog

December 18, 2006

This is where I am intending to document my experiences in the great wide world of FLOSS, although it’ll probably degenerate reasonable quickly into a big list of how to get shit working in Linux on my box.

be warned, I’m very forgetful so don’t expect daily updates or anything